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1 Software Overview 

Overview 

The UMD™ Image Generator (umdgen) is a tool that is used for creating UMD™ image files. 

 

Currently, no tools are provided to allow users to create UMD™ discs on their own. 

However, a UMD™ image that has been written to a DVD-R as a logical file can be used by the 

esting Tool (DTP-L1500/DTP-L1500A). T

 

To create a UMD™ image file using umdgen, first specify the required data files, then enter 

additional information to be added to the disc. 

UMD™ Image Files 

A UMD™ image file that is output by the UMD™ Image Generator actually consists of a group 

of 4-5 files. These files are needed to manufacture the UMD™. The files include 

USER_L0.IMG (Layer0) and USER_L1.IMG (Layer 1),which comprise the disc image and are 

in a format that is an extension to ISO 9660 Level 2. 

Operating Environment 

Th nerator re UMD™ Image Ge
Operating system 

uns in the following environment. 
Windows 98 (Internet Explorer 5.0 or later is 
required) 

 SP5 or later Windows NT 4.0
Windows 2000 
Windows XP 

CPU Pentium II 450MHz or faster 
RAM Min. 128MB 
Minimum free memory 16MB 

(*) More memory is required if a large number of 
source files are written. 
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2 UMD™ Image Generator Window 

UMD™ Image Generator Window Structure 

T

 

he UMD™ Image Generator window has the following structure. 

 
Figure 1 UMD™ Image Generator Window - Directory Mode 

 

The following buttons are arranged from left to right under the menu bar at the top of the 

window. 

 Volume button 

 Directory button 

 Layout button 

 Type of UMD™ image currently being created 

 Remaining number of sectors 
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Generate Image button 

 

The UMD™ Image Generator has three modes: Volume, Directory, and Layout. You can switch 

modes by clicking on the respective buttons. 

Directory Mode 

Fig. 1 shows Directory mode, where the directory and file configuration that is written to the 

UMD™ image can be edited. 

 

In Directory mode, the left hand side of the window contains the tree view, showing the overall 

directory configuration. The right hand side is the directory view, showing the files and 

subdirectories in the currently selected directory. 

 

In this document, data files written to UMD™ images are referred to as source files. 

 

Directory mode can be used to add source files and directories to UMD™ images in the 

following three ways: 

 

• By selecting the desired file or directory in Explorer, and dragging and dropping the file 

onto the UMD™ Image Generator window. 

• By pressing “Shift + Insert” while the UMD™ Image Generator is selected, or choosing 

“Put Files” from the “Edit” menu, and selecting the desired file or files in the open dialog 

window. 

• By pressing “Insert” while the UMD™ Image Generator is selected, or choosing “Put 

Directory” from the “Edit” menu and selecting the desired directory. 

 

To create a new directory, press “Ctrl-D” or choose “Create Directory” from the “Edit” menu. 
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Volume Mode 

 

 

Figure 2 Volume Mode 

 

In Volume mode, information about the UMD™ image being created such as the Disc Name, 

which indicates the disc product number, as well as the Copyright Holder and Producer Name 

can be edited. 
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Layout Mode 

 

Figure 3 Layout Mode 

 

In Layout mode, the layout of the sectors that contain the files that have been added to the 

UMD™ image, can be checked and updated. 

Although Layout mode allows files to be added to a UMD™ image while it is being created, 

these files are not recognized as files by the normal filesystem. 

 

The following information is displayed in this mode: 

“Start”: the first sector 

“End”: the last sector 

“Path”: the path of the file 

“Layer”: the layer where the file is located 

 
Files that appear in black are those that have been placed in the filesystem of the UMD™ 

image. 

Files that appear in red are reserved by the system, and cannot be relocated by the user. 

Entries that appear in blue represent files added in Layout mode, and are not seen by the 
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filesystem. 

 

Files may be added in Layout mode in the following two ways: 

• By selecting the desired file or directory in Explorer, and dragging and dropping it onto 

the window. 

• By pressing “Insert” while the UMD™ Image Generator is selected, or choosing “Put 

Files” from the “Edit” menu, and selecting the desired files from the open dialog window. 

Preference Window 

In addition to the above three modes, the UMD™ Image Generator has a Preference window 

for setting detailed preferences for a project. 

 

 

Figure 4 Preference Window 

 

To open the Preference window, select “Preference” from the Options menu. 

 

In this window, you can configure the “Layer Transparency” and “Force 16 sector alignment” 

settings. The "Capitalize File/Dir Name" setting allows file/folder names to be automatically 

converted to uppercase. 

Refer to Chapter 5, “Description of Operations,” for more information about these settings. 
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3 Usage Overview 

This chapter describes the typical procedure for using the UMD™ Image Generator, up 

through outputting a UMD™ image. 

Preparing Source Files 

Begin by preparing the source files which will be written to the UMD™ image. 

Launching the UMD™ Image Generator and Creating a New Project 

When the U

 

MD™ Image Generator first starts up, it displays the following window. 

 

Figure 5 UMD™ Image Generator at Startup 

 

The UMD™ Image Generator manages the creation of a UMD™ image as a single project. 

The UMD™ Image Generator’s Menu window displayed at startup enables you to either create 

a new project or open an existing project. 

ect “Create New Project” to create a new project. Sel
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Figure 6 Selection of Layer Configuration 

 

When the New Project dialog window appears, select the type of project you wish to create, and 

click OK. 

The following types of projects can be created: 

 

• UMD™ Single Layer 

Creates a new project to be used for a single layer UMD™ image. 

• UMD™ Dual Layer Image (OTP) 

Creates a new project for a dual layer UMD™ image (OTP). 

 

The UMD™ Image Generator’s default project type is UMD™ Dual Layer Image (OTP). 

Entering Master Disc Information 

The window for editing the directory configuration of the UMD™ image is automatically 

displayed when a new project is created or an existing project is opened. 

 

Click the "Volume" button at the top of the UMD™ Image Generator window to switch to 

Volume mode. 

In Volume mode, enter the required master disc information for the UMD™ image. 
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Figure 7 Volume Mode: Master Disc Information Input Example 

 

The following table gives detailed information about the information entered here. 

 
Input Field Input Data and Notes 
Disc Name Product number of the title. Maximum of 26 alphanumeric 

characters. 
The following symbols can be used:  | (vertical line), - (hyphen), and 
space. 
Do not use any other symbols as this may cause problems during disc 
manufacturing. 

Copyright Holder Name of the copyright holder. 
Max. of 32 uppercase letters, symbols, and digits. 

Producer Name Name of the producer. 
Max. of 32 uppercase letters, symbols, and digits. 

Region Code Selectable as "Region 1," "Region 2," "Region 1 + 2," or "World Wide." 
An arbitrary region can also be set by using "Manual." 

Volume Volume Identifier stipulated by ISO 9660. 
This entry can be omitted. 

Volume Set Volume Set Identifier stipulated by ISO 9660. 
This entry can be omitted. 

Publisher Publisher Identifier stipulated by ISO 9660. 
This entry can be omitted. 

Data Preparer Data Preparer Identifier stipulated by ISO 9660. 
This entry can be omitted. 
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Adding Source Files to the Project 

Click the "Directory" button at the top of the UMD™ Image Generator window to switch to 

Directory mode. Directory mode is used for specifying the files that will be included in the 

UMD™ image. 

 

Perform the following operations using Windows Explorer. In Explorer, select the files that you 

want to include in the UMD™ image and drag and drop them onto the Directory mode 

windows of the UMD™ Image Generator. They will be added to the project that is being 

created. In addition, if you press “Shift + Insert” while the UMD™ Image Generator is selected, 

you can select files that you wish to include in the UMD™ image in the dialog window that 

appears. 

 

Note 

Note that file names are case sensitive, so upper case characters are considered to be different from 

lower case characters. 

 

Outputting the UMD™ Image 

To output the UMD™ image, either click the "Generate Image" button at the top of the UMD™ 

Image Generator, or select “Generate Image” from the “File” menu. This will open the 

Directory Selection window. Select the desired output directory, and click “OK” to begin writing 

out the UMD™ image. The UMD™ image will be created in the specified directory. 

 

Should you choose to output to a directory that already contains either a complete or partial 

image file, a dialog window will appear warning you that the existing file will be deleted. If 

you want to proceed anyway, click “Yes,” and the new UMD™ image will be output, erasing the 

previous one. 

Saving and Loading Projects 

Choose “Save” from the “File” menu to save the currently open project. 

To load a saved project, either select “Load Project” from the “File” menu, or select “Open 

Project” in the startup dialog window and choose the desired project. 
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Writing to a DVD-R Disc 

Although the UMD™ Image Generator does not have a built-in function for writing the 

UMD™ image directly to a DVD-R disc, this can be done by first setting up the necessary DVD 

writing software, then writing the UMD™ image that was created by the UMD™ Image 

Generator to a DVD-R disc. The following points should be noted. 

 

• The disc must be created as a "data DVD." 

• All the files (four or five) that were created as the UMD™ image must be written to the 

root directory of the DVD. 

 

After the DVD-R has been successfully written, insert it into the DVD drive of the Testing Tool 

(DTP-L1500/DTP-L1500A) to use it. 
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4 Miscellaneous Functions 

Changing the File Layout 

Use Layout mode to change the layout of files in the UMD™ image. 

 

To move a given file, select the desired file in the Layout Edit window and drag and drop it to 

the desired location. You can also perform the same operation by right-clicking on the desired 

file and choosing “Move (select)” from the pop-up menu. Then, right-click on the destination, 

and choose “Move (insert)” from the pop-up menu. 

Generating a GUID 

To recognize different discs, the UMD™ Image Generator generates a 16-byte GUID whenever 

it creates a new project or loads an existing project. The GUID is then embedded in the 

UMD_DATA.BIN file that is located in the root directory. 

For information about reserved system files and directories, see "Reserved System 

Directories/Files" in "Description of Operations." 

To manually generate a new GUID, choose “Generate new GUID” from the “Edit” menu in 

Volume mode. 

Specifying Sector Numbers Directly 

You can manually arrange files by explicitly specifying their sector numbers, provided that you 

do so exclusive of the Automatic 16-Sector Alignment feature of the program. Refer to the 

section on this feature in the “Description of Operations” chapter of this document for 

ormation on how to deactivate Automatic 16-Sector Alignment. inf

 

To change sectors for a particular file, click the Layout button to enter Layout mode. Then, 

right-click the desired file, and choose “Location” from the pop-up menu. When the “Location” 

ow opens, enter the desired sector number in the “Location” field, and click OK. wind
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E

g the FILE 

LIST field in the project meta information file to the desired file list. 

The file list format is defined in Chapter 8, "Appendix: UMD™ File List Format." 

Im

he program can import a file layout list from an external file. To perform this operation, 

ion in 

 will 

ignore sector numbers stored in the imported file list. 

The file list format is defined in Chapter 8, "Appendix: UMD™ File List Format." 

E

s. 

o export a project meta information file, choose “Export Meta Info” from the “File” menu. 

set in the FILE LIST field in the project meta information file being exported. 

 

The project meta information file format is defined in "Appendix: UMD™ Meta Information 

 

Im

xporting File Lists 

The program can export a list containing file layout information to an external file. To perform 

this operation, choose “Export File List” from the “File” menu. 

 

You can load a file list at the same time that project information is loaded by settin

 

porting File Lists 

T

choose “Import File List” from the “File” menu. The imported file list overwrites informat

the currently open project. 

 

If “Automatic Sector Alignment” is enabled when a file list is imported, the program

 

xporting Project Meta Information Files 

The UMD™ Image Generator can export projects in progress as user-editable external file

These files are called project meta information files. 

T

Exporting a project meta information file also automatically generates a UMD™ file list, 

which is 

Format 

porting Project Meta Information Files 

The UMD™ Image Generator can import a project meta information file, making it 

unnecessary to enter the information directly when a UMD™ image is output. 
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To import a project meta information file, either choose “Import Meta Info” from the “File” 

enu, or select “Open Project Meta Information File” from the startup menu, click “OK”, and 

 

nding information in the currently open project. 

 

he project meta information file format is defined in "Appendix: UMD™ Meta Information 

ormat 

 

 

 

m

select the desired file. Importing a project meta information file from the menu will erase the

correspo

T

F
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5 Description of Operations 

Automatic 16-Sector Alignment Feature 

The starting sector numbers of all files are multiples of 16 in order to improve the efficiency 

and speed with which files can be read from the UMD™. 

By default, the UMD™ Image Generator automatically arranges all files on the disc so that 

this condition is met. This feature is known as “Automatic 16-Sector Alignment”. 

To turn this feature on or off, choose “Preference” from the “Options” menu, and set the “Force 

or Alignment” item as desired. 16 Sect

 

ved when a project is saved. The setting of the “Automatic 16-Sector Alignment” feature is sa

When the project is later reloaded, that setting is restored. 

Layer Transparency Feature 

The UMD™ Image Generator allows users to set for each project, whether files in a dual-layer 

UMD™ image are to be arranged so they extend from one layer to the other. This feature is 

known as “Layer Transparency”. It is “On” by default whenever a new dual-layer project is 

ed. creat

 

To turn this feature on or off, choose “Preference” from the “Options” menu, and set the “Layer 

Transparency” preference as desired in the Preference window. 

File/Folder Name Automatic Uppercase Conversion Feature 

The UMD™ Image Generator has a function for automatically converting file/folder names to 

uppercase. This function is also performed when files or folders are renamed. 

To switch this feature on and off, select "Preference" from the “Options” menu and then change 

the "Capitalize File/Dir Name" item in the Preference window. 

Automatic Padding 

The UMD™ specification requires that the final number of total sectors on the disc be a 

multiple of 16. For this reason, the UMD™ Image Generator automatically pads out the 

UMD™ image whenever it is changed, to maintain a proper total sector count. This padding is 
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always added at the end of the sequence of sectors. 

R

matically generates the reserved system directories 

quired by each application and the reserved files for distinguishing different titles, and 

hese are handled internally by the UMD™ Image Generator as system directories and files 

and cannot be deleted or renamed by the user. 

 

eserved System Directories/Files 

The UMD™ Image Generator auto

re

places them in the logical format. 

 

T
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6 Precautions 

Restrictions 

•

• 

• 

• 

•

•

• 

 You cannot set sectors manually if you are using forced 16-sector alignment. 

Items cannot be dragged and dropped from the left to right panes in the Directory mode 

window. 

Files must be placed on the second layer of a dual-layer UMD™ image. An error will 

occur if a dual-layer project is output that has no files located in the second layer. 

When the file layout is changed by directly specifying sector numbers, a file can be 

placed such that it extends across layers regardless of whether the “Layer 

Transparency” feature is enabled or disabled. 

Precautions when Creating UMD™ Images 

A UMD™ image must satisfy the following requirements. 

T e field in Volume mode.  he product number must be correctly entered in the Disc Nam

 The Region Code field in Volume mode must be correctly set. 

The Creation Date field in Volume mode must be correctly set. 
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7 Appendix: UMD™ Meta Information Format 

A UMD™ meta information file (umi file) is a text file that contains information required to 

e a UMD™ image project. The UMD™ Image Generator can output such files. creat

 

A UMD™ meta information file consists of three sections [SYS], [MDI], and [VOL], which are 

described below. The information contained in each section is given in the format 

FIELD_NAME=VALUE. 

 

If a line begins with a "#", it is considered to be a comment and is ignored. 

[SYS] Section 

The [SYS] section contains the following information, which includes information about the 

project itself. 
Field Name Required Function 
VERSION Yes Version (fixed value) 
APPLICATION Yes Application name 
LAYER_STRUCT Yes Layer structure 
FORCE16SECTOR No Use Automatic 16-Sector Alignment  
LAYER_TRP No Use Layer Transparency 
FILE_LIST No Name of file list 
BOOT No Indicates if this is a boot disc 
UPDATE No Indicates if update data is included 

VERSION 

APPLICATION 

•

FORCE16SECTOR 

This field contains the current UMD™ File List version number, "1.0”. 

The f es can be specified. ollowing typ

• PSP GAME 

• UMD VIDEO 

 UMD AUDIO 

This field controls the Au

0 to disable, 1 to enable. 

tomatic 16-Sector Alignment function. 
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LA

disable, 1 to enable. 

BO

ootable. 

s bootable, 1 means not bootable. 

UP

 update data. 

0 means the disc image contains update data, 1 means it does not. 

 UMD™ images that are not used for games. 

[

Th on conta o ation, which includes information related to 

UM isc Inf tion. 

YER_TRP 

This field controls the Layer Transparency function.

0 to 

Layer Transparency is ignored on single-layer discs. 

OT 

This field indicates whether the disc image is b

0 mean

Only valid for UMD™ images used for games. 

DATE 

This field indicates whether the disc image contains PSP™ system

Only valid for

MDI] Section 

e [MDI] secti ins the foll wing inform

D™ Master D orma

Field Name Requ Max. 
Chaired racters 

Function 

DISC NAME Yes N/A Title ID (product 
number) 

PRODUCER Yes 32 Producer’s name 
COPYRIGHT Yes 32 Copyright holder’s 

name 
REGION_CODE Yes N/A Region code 

 

DIS

D must be in the format ”XXXX-YYYYY”, where "XXXX" are capital letters, and 

PR

s name and copyright holder's name may each have a maximum of 32 

RE ION_CODE 

MD™ is set here, from among the following choices. 

C NAME 

The Title I

"YYYYY" are numbers. 

ODUCER 

The producer'

characters. 

G

The region code of the U

 

• 1 (US and Canada) 
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• 2 (Japan, Europe, Middle East, South Africa) 

• 3 (South Korea, Taiwan, Hong Kong, Singapore, Southeast Asia) 

, Oceania) 

, Russia) 

• 6 (China (excluding Hong Kong)) 

e) 

 

T ntains inf b ™ hich is recorded in the filesystem 

o  image. 

• 4 (Central America, South America

• 5 (South Asia, Africa

• WW (world wid

[VOL] Section 

his section co ormation a out the UMD  volume w

f the UMD™

Field Name Req Max. 
Characters uired Function 

VOLUME No 32 VOLUME ID 
PUBLISHER No 32 PUBLISHER 

NAME 
VOLUME SET No 32 VOLUME SET ID 
DATA PREPARER No 32 Data preparer 

Sample umi File 

AME" 

="SINGLE" 

RP=0 

"Test_file_list.ufl" 

1 

PDATE=1 

0001" 

U" 

IGHT="SCE" 

EGION_CODE ="WW" 

[SYS] 

VERSION="1.0" 

APPLICATION="PSP G

LAYER_STRUCT

FORCE16SECTOR=1 

LAYER_T

FILE_LIST=

BOOT=

U

[/SYS] 

 

[MDI] 

DISCNAME="TEST-0

PRODUCER="SCE TARO

COPYR

R

[/MDI] 

 

- 23 - 



SCE CONFIDENTIAL 
 

 
©SCEI                                                                          UMD™ Image Generator 
 

[VOL] 

VOLUME="TEST" 

PUBLISHER="TEST" 

VOLUME SET="TEST" 

ATA PREPARER="TEST" 

[/VOL] 

 

D

- 24 - 



SCE CONFIDENTIAL 
 

 
©SCEI                                                                          UMD™ Image Generator 
 

8 Appendix: UMD™ File List Format 

The UMD™ File List (ufl) file is used to identify the source files recorded in the UMD™ image. 

Information about each file is stored as a single one-line entry in CSV format. The following 

e information included in each entry. shows th

 
Field Name Required Function 
PATH_ON_DISC Yes Path information on the disc 
LOCAL_FILE_PATH Yes File path in environment where the UMD™ 

ed image was creat
SECTOR_ADDRESS No Sector address 
SIZE No File size 
FLAG No Additional information about the file 

PATH_ON_DISC 

T  examplehe following are
Null string ("") 

 values for this field. 
The path is not recorded in the UMD™ filesystem 
The filename from LOCAL_FILE_PATH is placed in the root 
directory on the UMD™. / 

The filename from LOCAL_FILE_PATH is placed in the /HOGE/ /HOGE/ directory on the UMD™. 
The file HOGE.DAT is placed in the /HOGE/ directory on the 
UMD™. /HOGE/HOGE.DAT 

LOCAL_FILE_PATH 

SECTOR_ADDRESS 

SIZE 

FLAG 

•

This is the file path beginning with the Windows-standard drive name. 

This field is used only when file sectors are manually specified. If this field is not set, the 

UMD™ Image Generator will automatically assign file sectors. 

This field is used only when the UMD™ Image Generator exports file lists. It is not 

referenced when file lists are imported. 

This fi g which indicates file attributes. The following types are supported: eld is a fla

• 1 (boot file) 

 Other (normal file) 
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Sam

", , ,  

 , ,  

pg", , ,  

"/Yosic.jpg", "C:\Storage\TempPic\Yosic.jpg", , ,  

"/ganden_05.jpg", "C:\Storage\TempPic\ganden_05.jpg", , , 

 

ple UMD™ File List (ufl) File 

"/ganden_02.jpg", "C:\Storage\TempPic\ganden_02.jpg

"/Potara_02.jpg", "C:\Storage\TempPic\Potara_02.jpg", , 563794,  

"/Sakya.JPG", "C:\Storage\TempPic\Sakya.JPG",

"/Tibetan_Dawn.jpg", "C:\Storage\TempPic\Tibetan_Dawn.j
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