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FilmMaker

Introduction

Welcome to FilmMaker! You are about to enter an amazing world of motion
and visual effects. The list of features in FilmMaker reads like a wish list of the

professional animator.

In FilmMaker, you will be designing your animations in an environment that
offers you real-time control over the path, position, scale, and rotation of
animated objects. This real-time feedback gives you the creative freedom that
you have previously only dreamed of. Rendering options, such as full-screen
anti-aliasing and anti-flicker processing, give you the highest-quality image
possible on your Macintosh. The ability to animate the colors and transparency
of objects brings dazzling visual-impact to your presentations. Hierarchical
links between objects on screen allow you to easily create elaborate and
complex animations. FilmMaker does the kind of work for you that would
otherwise require hours of tedious manipulation of your artwork.

These Quick-Start Tutorials will familiarize you with how to use the different
animation tools in FilmMaker. Brief explanations are included, but you will
want to refer to the FilmMaker manual if more detailed questions arise.

An Overview of FilmMaker
FilmMaker has divided the process of creating animated graphics into

specialized modules. The flow chart below describes the process of creating
animations in FilmMaker.
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introduction

The Mark module
This application is used to draw simple wireframe outlines on top of your

phari artwork. These outlines are used as references to your artwork when
designing motion in the Animate module. In the Mark module you may:
* Import PICT, PICS, or EPSF files
* Export PICT or PICS files
* (Create wireframe outlines for use in Animate
* Add and delete frames of an animation

The Color module
ﬁﬁﬂ This application is used to animate the colors in a graphic. After the color

animations are saved in the Color module, they may be imported into the

Color Animate module. There are some significant benefits to separating these two
tasks. One is the fact that the Animate module combines animations into a
32-bit environment, which can accommodate graphics with differing palettes,
then converts the composite images back into 8-bits. This process saves the
user from performing complex color table manipulations to make room for
them in the one 8-bit palette. Objects that have animated color tables will also
be accommodated. In the Color module you may:

 Import PICT, PICS, or EPSF files

e Export PICT or PICS files

* Animate the colors used in graphics

* Add and delete frames of an animation

The Animate module
This application is used to define motion, scaling, transparency and
. rendering effects over the length of an animation. Artwork brought in
Animate through Color and Mark is combined in Animate. As stated above, graphics
with different palettes and from different sources can be combined into an 8-
bit animation without manually customizing palettes. Animations generated
in Animate can be further edited in Mark or Color. The majors features of
Animate are:

* Define movement, scaling and rotation of objects.

* Animate the transparency of objects.

* Render an animation with effects such as full screen anti-

aliasing, dithering and anti-flicker for output to video.
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The Sound module
This application allows you to add sound to your animations.

The Present module
Present allows you combine animations and still images into an interactive
environment. Present uses a graphical flow chart to lay out sequences of
interaction. Some major features are:
¢ Create buttons and overlay them on animations and
graphics.
* Define keyboard commands for user interactivity.
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Mark Tutorial

- FilmMaker Tutorial #1:
- Using the Mark module

The Mark Module

The Mark Module is a very straightforward application. It is simply an
interface for drawing your own customized wireframes on top of your
artwork. When the artwork is imported into the Animate module, you will
see that you have real-time control over such operations as the path, rotation,
- and scale of your artwork as it is animated on the stage. It is not possible to
do such operations on complex artwork in real-time, so FilmMaker allows
you to design your animations while moving your wireframes on the stage.
After you have finished defining the motions, FilmMaker then repeats the
motions with the original artwork.

In this tutorial, we will import a PICT file and create a customized mark for
use in the Animate module. A simple example for use with this tutorial is
provided on the tutorials disk. Follow the step-by-step instructions below to
introduce yourself to the FilmMaker Mark interface. If you desire more

| detailed explanations, please refer to the FilmMaker manual.

Launch the Mark module.

A dialog box appears offering you the opportunity to open files which have
already been saved in the FilmMaker file format. Click on the Cancel button

to proceed into the Mark application without opening any files.

Choose Import from the File menu.

A dialog box appears allowing you to designate the type of file being
imported. Click on the PICT button, and import the file Fire Ext. PICT
included on the tutorials disk by clicking Import.

This is a simple PICT document which we will later import to the FilmMaker
Animate module. Notice the crawling lines indicating a square surrounding
the artwork, this is the default Mark. If we were to import this artwork to
animate without modifying the Mark, we would see this square as the
wireframe of this artwork.
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Delete the default Mark.
With the arrow tool selected, click once on each of the four lines that make up
the Mark surrounding the fire extinguisher. Then delete each one using the

| delete key on your keyboard.

Select the Line tool from the Mark tool palette.

You may now draw your own customized wireframe on top of the artwork.
When animating the artwork, you want enough information to easily tell the
top and bottom of the graphic, the extreme right, left, or other extremities of the
graphic. The Line tool allows you to draw one straight line at a time. With the
tool selected place the cursor where you want a line to begin, click and drag to
the line’s endpoint, then release the mouse button to end the line. For this
graphic, we suggest trying to mimic the mark shown in the illustration below.

Original Artwork Marked Artwork

Figure M-1
Simple Mark example
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Save the Document.

Choose Save As from the file menu, name the document “Fire Ext.Ref” and
click the Save button. The file is now saved in the FilmMaker format and is
ready to be used as part of an animation. In the Animate application, artwork
prepared in Mark will be imported as a Reference, allowing the wireframe to
act as a stand-in for the original artwork. It is a good idea to add the suffix
“Ref” to the document name to distinguish it as a Reference.

Quit the Mark module.
Choose Quit from the File menu.

Summary
As you now see, the Mark module is very simple application. In the Mark

module, you create wireframes over existing artwork for use in the Animate
| module. You may also use the Mark module to export PICT and PICS files

from your FilmMaker files, and to add, delete, copy and paste frames of
animation.



FilmMaker Tutorial #2:
Using the Animate module

The Animate module
The Animate module is the central component of the FilmMaker program. In

Animate, the elements of an animation are brought together, given motion and
any of the many visual effects possible in FilmMaker. In this tutorial, we will
import an image that has been marked in the Mark module, and animate it
moving and spinning along a path.

Launch the Animate module.
On your screen will appear an empty stage, ready for you to import artwork
and set it to motion. The diagram below shows the different windows of the
Animate module with a brief explanation of their function.
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The Animate windows and their functions
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Choose Open Reference from the File menu.

Locate the FilmMaker file “Fire Ext.Ref” which contains a simple PICT image
which has been marked in the Mark module. Click once on the Open button
to import the artwork into FilmMaker.

Choose Reference from the Window menu.

A new window appears, as shown in the figure below, showing the artwork
you have just imported. Some useful information about the artwork is also
displayed.
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Figure A-2
The Reference window

Choose Create Object from the Edit menu.

Notice as you do this that the word Object appears in the Time and Tree
windows. This represents an animation object which has not yet been
assigned a piece of artwork.

Assign artwork to the animation object.

To designate that the PICT image “Fire Ext.Ret” should be associated with
this object, simply double-click on the artwork in the Reference window, and
it is automatically put in the place of the object selected in the Time or Tree
window. The wireframe that was created in the Mark module is displayed for
the purposes of designing the motion. It will later be replaced by the original
artwork when the Film Sequence function is called. As explained earlier, this
wireframe substitute is used to allow you to have real-time, interactive
control over the object’s motion, rotation, and scale, without having to wait
for the computer to do the complex operations required to rotate and distort
the original artwoerk while you are designing the animation.
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Close the Reference window.
Click the close box in the upper left hand corner of the Reference window.

Understanding animation objects
One of the Animate module’s most powerful features is its ability to physically

link animation objects together. The following characteristics of animation
objects are vital to understanding these links.

e Each animation object has the ability to move, scale and
rotate (roll) independently.

* Each object has its own Anchor Point (point of rotation).

e Animation objects may or may not have artwork assigned
to them.

Linked animation objects will move, scale, and roll with the objects that they
are connected to. This enables you to create very elaborate animations with a
minimum of time and effort.

Introduction to the Animate module’'s tools

Familiarize yourself with the name of each tool, in this tutorial we will be using
the Anchor Point, Move, Scale and Roll tools. The modifier tools are explained
in detail later in the manual.

— Anchor Point tool
— Move tool

— 5cale tool

— Roll tool

— Direction Modifier

— Path Modifier

— Speed Modifier

Figure A-3
10 The Animation tool palette
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An Important Note on Technique
When you are using the animation tools, you may select the tool then click
and drag on the wireframe of the object that you wish to operate on. For

' instance; if the Roll tool is selected, then you will rotate the object that you
click on about its Anchor Point. However, to define certain types of motion it
is sometimes necessary to create invisible animation objects (objects with no
artwork assigned to them) and then link objects with artwork to the invisible
object. Because you will be manipulating objects with no wireframe, it is a
very good idea to get in the habit of using the following technique:

* Select the object that you wish to manipulate by clicking
on its name in either the Time or the Tree windows

* Select the animation tool that you wish to use.

* Hold down the Control key on your keyboard, then click
and drag in the white area of the Stage window. Be
careful not to click on any of the objects on the screen.
The selected object will respond exactly as it would have
if you had clicked directly on it.

Using the Move, Scale, and Roll tools

All objects default with their anchor point in the upper left corner of the
stage. Select the Anchor Point tool and using the Control key technique
described above, drag the anchor point for the fire extinguisher an inch or
two away from the upper left corner so that you can see the relationships
between them. Practice selecting the Move, Scale and Roll tools and
manipulating the fire extinguisher on your screen. Observe the interaction
between the artwork and its anchor point. Notice that the artwork scales and
rotates relative to its anchor point. Also remember to practice using the
Control key technique described above. If the fire extinguisher “disappears,”
you may have scaled or moved it to such an extreme that it is no longer
visible. Be sure to choose Undo from the Edit menu if you lose an object.

Now that you have learned how to manipulate the object on screen, and
about the relationship between the object and its Anchor Point, you are ready
| to create an animation.

11
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Close the file you are experimenting on.
You don’t need to save the file, so click the No button when you are asked if
you wish to save.

Choose New from the File menu.

The fire extinguisher Reference that you imported will remain in the Reference
window until you quit the Animate module. Choose Reference under the
Window menu. You should see the Fire Ext.Ref file in the Reference window. If
for some reason you have quit since performing the last section of this tutorial,
you will need to import the marked PICT file again.

Choose Create Object from the Edit menu.

Just as before, this will place an empty animation object into the Time and Tree
windows. The Anchor Point for this object is located in the upper-left corner of
the Stage window.

Choose Name from the Object menu.

A dialog box appears offering you the opportunity to name the object. Type in
“Master”, and click the OK button. Notice that the first object will now be
referred to as “Master” in the Time and Tree windows. This helps you stay
organized when working with more complex animations.

Choose Create Object again.

This creates a new animation object which is linked to the currently selected
object (in this case, the “Master” object). This link will allow you to use the
“Master” object as a sort of invisible “sled” for this new object ride on.

Assign a piece of artwork to the second object.

To do this, simply click the new object in the Time or Tree window and double-
click on the fire extinguisher in the Reference window. The name of the artwork
file will immediately replace the name “object” in the Time and Tree windows,
and the wireframe of the artwork will appear on stage.

Close the Reference window.
Click the close box in the upper left hand corner of the Reference window.
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Before Proceeding
Understand that the link between the fire extinguisher object and the

invisible Master object will allow you to control the extinguisher’s scale and
roll independent of its movement. The invisible Master object will be used to
Move the fire extinguisher about on the screen. When Scale or Roll is desired,
you will use the extinguisher object itself. The reason for this is that you need
the Anchor Point for the artwork to travel on-screen with the artwork. This
will allow you to rotate the artwork about its center, or about a point in or
around the artwork that you choose. Remember to use the Control key
technique described earlier!

Select the Anchor Point tool.

All objects default with their anchor point in the upper left hand corner of the
stage. Make sure the fire extinguisher object is selected in the Time and Tree
windows, then use the control key technique to drag the extinguisher’s
anchor point (displayed as a large X on the Stage) towards the center of the
Stage.

Select the Move tool.

With the fire extinguisher object selected in the Time or Tree window, move
the artwork on screen up and to the left so that the anchor point is
somewhere in the middle of the artwork, as shown in the illustration below.
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Figure A-4
The artwork with Anchor Point in its center

Select the Scale tool.

Using the Control key to operate on the selected object, reduce the scale of the
fire extinguisher by dragging the cursor towards the right of the Stage until the
object is roughly a third of its original size. We will use this as the first frame of
our animation. Your screen should appear much like the one shown below.

------
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Figure A-5
Animate screen after scaling object

Extend the lifetime of the artwork object to 25 frames.

Select the “Fire Ext.Ref” object in the Time window, and pull down the Object
menu. Under the Specify sub-menu choose Last Frame. A dialog box appears
asking you to specify the last frame number that the fire extinguisher object is
| to be on stage. Enter 25 frames and click OK. Notice that the Time window

| extends out to 25 frames. There is a thin vertical line graphically indicating

' which is the current frame, and the current frame number appears in the
upper-left corner of the Time window. We have made no changes in the
object as it appears on the stage, so this is simply 25 frames of the object
standing still. The Time window should appear as shown below.

15
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Figure A-b6
The Time window ind icating 25 frames of animation

Moving the object.

We will now move the object along a path. To move the object, select the Master
object in the Time or Tree window, and select the Move tool from the animation
tool palette. Since the Master object is invisible, remember to use the Control
key technique to manipulate the object without clicking directly on any of the
objects on stage. Drag the object down to the lower-right corner of the screen.
To display objects’ paths in an animation, we may choose All Objects and All
Frames under the Display menu. This will display all of the frames on screen at
one time. Observe the path as it is described on screen. If you do not see
multiple copies of your object on screen as seen in the illustration below, be
certain that All Objects and All Frames are selected under the Display menu.
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Figure A-7
The Animate window displaying a straight line path

Choose Find from the Search menu.

A dialog appears asking you to enter the frame you would like to go to. Enter
the frame number 12 and click OK. Notice that the vertical line and frame
number in the Time window now indicate that you are at frame 12 of the
animation. Using exactly the same technique as before, use the Move tool, the
Master object, and the Control key to move the object in frame 12. Drag the
Master object to the lower left corner of the Stage. Notice that you now have
a curved path indicated on the screen, much like the one shown below. There
are many levels of precision with which a path or object position may be
described. These are explained in more detail in the FilmMaker manual.
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Figure A-8
The Animate module indicating a curved path

Previewing the Motion
To view the wireframe object in motion, rewind the sequence by choosing First

in Sequence from the Search menu, and Run Sequence from the Window menu.
After the animation plays, you may use the down arrow key on your keyboard
to play the sequence backwards. The up arrow key plays the sequence forward
again, while the right and left arrows key let you step forward and backwards
one frame at a time. Click on the screen to return to the Animate interface.

Rolling and Scaling the object as it moves
Choose Last in Sequence from the Search menu to move yourself to the last

frame of the animation. Remember that we used the Master object to Move the
object about on the screen, but we will now use the object “Fire Ext.Ret” to
Scale and Roll. Select the “Fire Ext.Ref” object in the Time or Tree window.
Select the Scale tool. Using the Control key to manipulate the object without
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touching any objects on screen, drag the cursor towards the left side of the
Stage to increase the scale of the artwork in the last frame. Notice that the
scale is smoothly increased across all of the frames. The scale may also be

' entered with keyboard input by choosing Scale from the Specify sub-menu
| from the Object menu.

You may use exactly the same techniques to rotate the object. Experiment

with these tools, and use the Run Sequence command to preview your

changes. Remember to choose First in Sequence from the Search menu before
using the Run Sequence command.

Figure A-9
Animated path with scaling and rotation added
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Using the Film Sequence command
When you are ready to compile an animation you will need to set the rendering

controls in the Stage dialog. Choose Stage from the Display menu. The dialog
shown below will appear. Different rendering settings are available for the Film
Sequence command. For the animation we have just created, the suggested
settings are shown below. Set the Anti-aliasing to simple, and turn the
Dithering function on. The Stage dialog is described in detail in the FilmMaker
manual. There is a new feature not explained in the manual, the Anti-flickering
option. This is a special kind of anti-aliasing function designed to enhance
transfer to videotape. This will help to avoid the image flicker which typically
accompanies high contrast horizontal lines when the screen is recorded to
videotape through conversion to NTSC or PAL signals.

e Sl e |
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= Depth Antialiasing —
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Dithering {< Remapping

[] Antiflickering [ System Palette

Step: 1= frames

Figure A-10
The Stage dialog: suggested settings for typical
animation
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Choose Film Sequence from the File menu.

A dialog box appears asking how many frames you want to render. The
default is all frames, so simply click OK, and to designate where on your disk
you want the file to be saved. FilmMaker will now repeat the motions you
have described in the wireframe environment of Animate, and will do the
selected rendering operations on the images on screen. This will take about
10 to 45 seconds per frame depending on the machine you are using, and the
rendering options you have selected. When the process is complete, you may
quit Animate and open the sequence using the Sequence Runtime application
included with FilmMaker. Note that you will then have two files:

e The Animate file which contains the artwork and path
descriptions may be saved and edited in the future.

* The Runtime sequence which is the compiled “movie”
may be viewed using the runtime applications included
in FilmMaker, and may be imported into Mark, Color,
Sound, or Present for further processing. This file may
also be imported into Animate and used as one
animation object to be combined with other images and
animations. You may choose to import the sequence into
the Color or Mark modules to extract a PICT image of an
individual frame of the animation, or to export a
standard PICS file of the animation to import to other
animation and presentation programs.

Other Animate Features
There are numerous features in the Animate module which we have not even

begun to explore. They are well documented in the FilmMaker manual. This
tutorial is intended to give you a solid understanding of the application and
how to use the different tools, windows, and modules.

One very popular feature is the ability to animate the transparency of an
object. (i.e. Set the values to 0 at frame 0, and 100 at frame 20.) When the
Film Sequence command is used, the object will slowly fade into view
between frame 0 and frame 20. This effect is particularly dramatic for objects
moving in front of complex backgrounds.

21
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FilmMaker Tutorial #3:
Using the Color module

The Color Module

The Color module is used for the modification and animation of colors used in
artwork being imported into FilmMaker. The Color application works on only
one file at a time. The output of Color is then imported into Animate to be
combined with the other elements of your animation.

In this tutorial, we will perform two different kinds of color animation:

Color Interpolation The Color module allows you to change (interpolate) any
color in an image over time.

Color Cycling The Color module allows you to shift (cycle) colors in an
image over time. This gives the illusion that the colors are moving in the image

itself.

The PICT and PICS files used in this tutorial are located on the Tutorials disk.
The following tutorial contains step-by-step instructions to familiarize you with
the FilmMaker Color interface. If you desire more detailed explanations, please
refer to the FilmMaker manual.

Color Interpolation Tutorial

Launch the Color module.

A dialog box appears offering you the opportunity to open files which have
already been saved in the FilmMaker file format. Click on the Cancel button to
proceed into the Color module without opening any files.

Choose Import from the File menu.

A dialog box appears allowing you to designate the type of file being imported.
Click once on the PICS button, locate the file “Spinning Ext.PICS,” and click the
Open button to import the file.

The file which you have just imported is typical PICS output from Swivel 3D
Professional. The file contains 40 images of the fire extinguisher which together
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make an animation of the extinguisher spinning. (The PICS file format contains
multiple PICT files strung together to form an animation file.)

Choose Run Sequence from the Window menu.

This allows you to preview the animation. Notice that the arrow keys on your
keyboard allow you to control the animation. The up arrow key plays the
animation forwards, the down arrow key plays it backwards, and the right and
left arrow keys allow you to step through the animation one frame at a time.

Click once on the screen to return to the Color controls.

You are now going to use the Color module to change (interpolate) the color of
the fire extinguisher as it spins. Before proceeding, study the diagram below to
familiarize yourself with the different windows of the Color module.
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Figure C-1
The Color module windows

Using the Time window

Notice that the Time window has two rows of tiny squares with numbers above
them. The top row of squares, referred to as the Frame, allows you to move to
different frames in the sequence. The bottom row, referred to as the Range,
indicates the frames which are currently selected. 23
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Move to frame ten in the Time window.

In the Frame row (top row), click on the square below the number 10. This
advances you to frame ten of the sequence. Notice that the screen updates to
the new frame and the new frame number is displayed to the right of the word
“Frame” in the Time window.

When you edit colors in the Color palette, the colors for the currently selected
frame are changed.

Select the colors to be interpolated.

| Move your cursor into the document window and note that the cursor changes
| to an eyedropper. Click and drag the eyedropper over the chrome portion of
the fire extinguisher. Notice that the colors are automatically selected in the
palette window.

The fire extinguisher image was created in Swivel 3D Professional. Swivel
organizes the palette into ramps of color going from white, to the object color,
and then to black. Since the chrome portion of the extinguisher is made entirely
of shades of gray, we will select all the grays in the color palette. While holding
down the Shift key on your keyboard, click and drag from white in the upper
left of the palette window to black in the lower right of row four (see Figure C-

2),
b R R
Selection: &3
11
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Figure C-2
The Palette window with all shades of gray correctly
04 selected.
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Understanding colors

The screen on your computer uses red, green and blue beams of light to
display colors. A combination of red, green and blue at their maximum
intensity produces white on your screen. When red, green and blue are all

| turned off, black is produced on the screen. All colors between white and

| black are produced using varying combinations of red, green and blue. The

' Toolbox in the Color module allows you to edit colors by selecting them from
the Palette window, then adjusting their red, green and blue components.

Modify the red color component.

In the Toolbox (as labeled in figure c-1), select the red component by clicking
on the “R” button. In the right portion of the Toolbox is a scroll bar. To lower
the intensity of the selected component (red in this case), click and drag the
square in the scroll bar down. Notice as you do this that the colors in the
color table and on the image change.

Modify the green and blue color components.

Click on the “R” button in the Toolbox to deselect the red color component.
Select the green and blue components by clicking on the “G” and “B” buttons
in the Toolbox. Click and drag the scroll bar up. Notice as you do this that the
colors in the color table and on the image change. The chrome area of the fire
extinguisher should now have a greenish-blue tint to it.

Check your work.

Keep in mind that since ten was the selected frame in the Time window, only
the colors in frame ten were modified with the Toolbox. Check this by going

' to frame zero in the Time window. To do this, click on the square below the

' number 0 in the Frame row (top row). Notice that the palette and image have
not been altered in frame zero. Return to frame ten by clicking the square
below 10 in the Frame row. Notice the changes made in frame ten are still
there.

Select the frames to be interpolated.

Click and drag your cursor from frame zero to frame ten along the Range
row (bottom row) of the Time window. This tells the color module that you
want to animate the chrome color changing it from its original gray in frame
zero to the greenish-blue in frame ten.
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Select the red, green and blue components in the Toolbox.

Click on the “R” button in the Toolbox so it is highlighted. The “G” and “B”
buttons on the Toolbox should still be selected. If they are not, click on them so
they are also highlighted. Since you altered all three components (red, green
and blue), they must all be selected before proceeding.

Choose Interpolate from the Effects menu.
The Color module now computes the changes of red, green and blue from
frame zero to frame ten.

Go to frame twenty in the Time window.

Click on the square below the number 20 in the Frame row (top row). Note that
the colors in frame twenty have not been modified.

Select frames ten to twenty in the Time window.

Click and drag your cursor from frame ten to frame twenty along the Range
row (bottom row) of the Time window. This tells the Color module that you
want to animate the chrome color changing it from the greenish-blue in frame
ten to its original gray in frame twenty. Make sure the “R,” “G" and "B”
buttons are all selected on the Toolbox before proceeding.

Choose Interpolate from the Effects menu.

The Color module now computes the changes of red, green and blue from
frame ten to frame twenty.

Choose Run Sequence from the Window menu.

The Color module now plays your animation with the color interpolations you
specified. Remember to use the down arrow key to play the sequence
backward, the up arrow key to play it forward, and the right and left arrow
keys to step through the sequence.

Click on the screen to return to the Color interface.
Congratulations, you have just created a color interpolation animation!

Choose Save As from the File menu.
Name the file “Spinning Ext.Ref” and click the Save button. The PICS file with
the new color interpolation information is now saved in the FilmMaker format.



The file can be imported into the Animate module as a Reference and
combined with other artwork. It is a good idea to add the suffix “Ref” to the
document name to distinguish the file as a Reference. You may also play this
file using the Sequence Runtime module.

Color Cycling Tutorial

' Launch the Color module.

| Adialog box appears oftering you the opportunity to open files which have
| already been saved in the FilmMaker file format. Click on the Cancel button
| to proceed into the Color application without opening any files.

Choose Import from the File menu.

A dialog box appears allowing you to designate the type of file being
imported. Click once on the PICT button, locate the file “Background.PICT”
and click the Open button to import the file.

This image is a gradient fill background. Consult the manual for your paint
program for instruction on how to create a gradient fill effect.

Select the frame 0 in the Frame row of the Time window.

Choose Duplicate Frame from the Edit menu.

A dialog box appears asking you to enter the number of frames of color
animation you wish to create. For this example, enter 30 frames and click OK.
Notice that the Time window shows that there are now thirty frames of this
picture. This does not mean that there are 30 copies of the picture, only that
there will be thirty frames of animation associated with it.

From the Edit menu, choose All Colors from the Select sub-

menu.

In this example, we will cycle the entire color table of the image. It is possible
to select portions of the color table for cycling by following the steps outlined
| in the color interpolation tutorial.

Select all frames in the Range row of the Time window.
Click and drag from frame 0 to frame 30 in Range row (bottom row) of the
Time window. This tells the Color module which frames the color cycle will
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Choose Cycle Right from the Effects menu.

A dialog box appears asking for the information needed to set up the
animation. Enter 1 for the Number of Cycles, and click OK. Notice that as the
Color module compiles the sequence, the colors in the Color palette are being
shifted to the right for every frame of the sequence.

Choose Run Sequence from the Window menu.

You have now created a color cycling animation. You may now view the
animation being played back at full-speed. Remember to use the down arrow
key to play the sequence backward, the up arrow key to play it forward, and
the right and left arrow keys to step through the sequence.

Choose Save As from the File menu.

Name the file “Background.Ref” and click the Save button. The file with the
new color cycling information is now saved in the FilmMaker format. The file
can be imported into the Animate module as a Reference and combined with
other artwork. It is a good idea to add the suffix “Ref” to the document name to
distinguish the file as a Reference. You may also play this file using the
Sequence Runtime module.

Going to Animate

An important feature of FilmMaker is that the Animate module allows you to
combine different pieces of art and animation with different palettes. You may
also import different versions of artwork with different animated color tables
without having to juggle the positions in your color palette to make room for
them. This is possible because FilmMaker composites all of the animations into
a 32-bit “stage.” If 8 bit output is desired, then the entire stage is dithered back
down to 8 bits using a high-quality diffusion dithering function, anti-aliasing
the entire stage in the process. This provides the highest-quality screen image
possible. This means that you can easily create complex and dramatic
animations without doing complicated and time consuming color table
manipulations yourself. FilmMaker does them for you.



Color Tutorial

Summary

The Color module is a very straightforward interface for animating the colors
of existing artwork. The artwork is then saved as a FilmMaker file for import
to the Animate module.

Color may also be used to duplicate and delete frames of an animation or to
extract PICT and PICS files from an existing FilmMaker file.

You have now been introduced to the set of animation tools available in
| FilmMaker, but we have only scratched the surface. Consult the
| FilmMaker manual for questions concerning other features and
| modules not covered in these tutorials.
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